파이어폭스 "이 페이지는 약한 암호화를 사용합니다" 경고 표시

기술자료, 설치/적용 이슈 주요 사례

최신 업데이트 버전 파이어폭스에서는, 웹서버에 접속할때 낮은 암호화 수준으로 연결될때, URL 경로창 아이콘으로 아래와 같은 경고 메시지를 표시해 주고 있습니다. (앞으로 대부분의 웹브라우져에서 차단 예정으로, Firefox 에서는 미리 경고 표시 진행중)







"이 페이지는 약한 암호화를 사용합니다"
"이 사이트에 안전하게 연결되어 있지 않습니다"
"이 사이트의 연결이 약한 암호화를 사용하고 있어서 보호되지 않습니다"
"다른 사람이 정보를 보거나 웹사이트의 동작을 바꿀수 있습니다"


이와 같은 표시는 웹브라우져에서 웹서버 접속시  SSL v2 v3 TLS 1.0 1.1 버전 및 128 bit 수준 연결될수 밖에 없는, 즉 웹서버가 낮은 수준의 암호화만 지원하기 때문에 네트워크 암호화 보안에 문제가 있을수 있다 라고 표시를 해주는 것입니다.




최신 네트워크 암호화 버젼은 TLS 1.2 또는 1.3 입니다. 그리고 256 bit 연결이어야 합니다. 이 버전을 웹서버에서 충족해야만 경고 표시가 발생하지 않습니다. 해결 방법은 웹서버의 암호화 라이브러리 수준을 최신으로 설정/업그레이드 해야합니다. (https 연결을 처리하는 보안 장비도 대상) 

▶ Apache, NginX, Lighttpd, HAProxy 등 웹서버 SSL Cipher Suite 설정 권장 값
   https://www.securesign.kr/guides/kb/42

낮은 수준의 암호화를 계속 유지하는 경우 해당 웹서버에서 운영하는 모든 웹사이트 접속이 차단될수도 있습니다.

▶ Chrome, Edge, IE, Firefox, Safari 주요 웹브라우져 TLS 1.0, 1.1 지원 삭제 (2020년 완료 예정)
   https://www.securesign.kr/guides/kb/49

▶ TLS 1.0 1.1 1.2 1.3 Protocol Compatibility (Browsers, Desktop, Mobile, Servers, Libraries)
   https://support.globalsign.com/customer/portal/articles/2934392-tls-protocol-compatibility

컨텐츠의 무단 전제복사를 허용하지 않습니다 (일부 인용시 출처 표기 필수)
본 사이트내 노출된 이메일 주소의 수집/이용을 일체 허용하지 않습니다